Thread: bugdust
View Single Post
Old May 24th, 2008, 08:14 AM   #105
bugdust
Forum Member
 
bugdust's Avatar
 
Join Date: Dec 2002
Location: Middleburg, FL USA
Posts: 8,812
Member Photo Albums
Default Re: bugdust

A little update...
I had to make a panic stop about a month ago on the way home from work in the bug. The brakes didn't stop me as well as I would have liked them to. I had new rear shoes on the shelf in the garage and had already put new shoes on the front. So, when I got home I jacked the bug up and put it on stands. My bug is so low I have to drive up on home-made ramps to get the front up and then I can get a jack under the rear torsion bar cover. But, I have to put the front on stands or the bug will sit on the front apron as soon as I start to lift the rear. So, when I lifted the front I noticed the beam needed a little help.

It looks like the PO didn't weld up the 6" beam when he built it. I decided to just weld this beam up on the car for now and build a new beam when I switch out the body. 57Drag came by and we boogered it up so it will hold.

I got the drums off and found this.

The shoes were a little thin on the left side and coming apart on the right. The retainer spring was cut in half and the pin gone.


It looks like this now except I switched out the top spring for the correct one.



Ended up with new bearings, axle seals, wheel cylinders, shoes and springs. 57Drag did the bearings and seal for me and made fun of me for painting the other stuff.

Got wheels?
__________________
my photobucket page

Quote:
No pics, but oh well, if you really, really need to see metal removed, turn off your computer and work on your car... ~ Ray-Dean

Last edited by bugdust; May 24th, 2008 at 08:19 AM.
bugdust is offline   Reply With Quote